0 votes
asked in ESPaper by (120 points)
Hi!

While my ESPaper worked perfectly for quite a time now, it only shows 3 horizontal lines after flashing shortly with the usual data and pictogramms. I can see it logging over the serial port and a first look on solder joints and the flexible cable did not reveal anything suspicious...

Has anyone an idea where to look for the culprit?

Kind regards,

Taki
commented by (9.9k points)
Are you using the latest version of our Mini Grafx driver?

Generic Test
Also, please make sure that the flat display cable sits properly in the PCB connector. You can try to release the latch which holds the cable in place, pull out the cable, clean it with alcohol and put it back in once it's dry.
commented by (120 points)
Sorry for the delayed reply; I was on a business trip.

I used 1.2.2 and the latest software from github. The error appeared when I had the previous Mini Grafx compiled and this did not change after using 1.2.2.

I tried the espaper-client package and there the screen worked, so I'd suspect that it's not a hardware error. I'll try your tip above and report my results.

Thanks for taking the time to answer me.
commented by (120 points)
I tried compiling again with the newest libraries (Mini Grafx 1.2.3 and ESP8266 Weather Statuib 1.6.6), but it still doesn't work.  I'm getting the following output on the serial port:

***********set register  end**********
Loading config
WIFI_SSID = [xxxx]
9
WIFI_PASS = [yyyy]
9
UPDATE_INTERVAL_MINS = [20]
20
TIMEZONE = [Europe/Berlin CET-1CEST,M3.5.0,M10.5.0/3]
8
NTP_SERVERS = [0.europe.pool.ntp.org,1.europe.pool.ntp.org,2.europe.pool.ntp.org]
11
DEVICE_ID = [uuuu]
9
DEVICE_SECRET = [vvvv]
13
Loaded config
State: 1
[xxx][yyy]....
About to call OpenWeatherMap to fetch station's current data...
Getting url: http://api.openweathermap.org/data/2.5/weather?id=zzz&appid=www&units=metric&lang=de
[HTTP] GET...
[HTTP] GET... code: 200
start document
Getting url: http://api.openweathermap.org/data/2.5/forecast?id=zzz&appid=www&units=metric&lang=de
[HTTP] GET...
[HTTP] GET... code: 200
start document

Waiting for time
WiFi: 90%
Min temp: -1.500000, max temp: 12.110000
Writing buffer
full init
***********set register Start**********
***********set register  end**********
Going to sleep

Please log in or register to answer this question.

Welcome to ThingPulse Q&A, where you can ask questions and receive answers from other members of the community.

https://thingpulse.com

...