0 votes
asked in Touch Interface by (120 points)

My display just flickers after uploading program.  I have used the latest software at https://github.com/squix78/esp8266-weather-station-color/

Below is a copy of the serial output

15
..PIFFS opened: 
[HTTP] GET...
[HTTP] GET... code: 200
start document
[HTTP] GET...
[HTTP] GET... code: 200
start document
0: Sunday
1: Sunday Night
2: Monday
3: Monday Night
4: Tuesday
5: Tuesday Night
6: Wednesday
7: Wednesday Night
8: Thursday
9: Thursday Night
10: Friday
11: Friday Night
[HTTP] GET...
[HTTP] GET... code: 200
start document

DST Rules Updated:
DST Start: Sun Mar 12 02:00:00 2017
DST End:   Sun Nov 05 01:00:00 2017

[HTTP] GET...
[HTTP] GET... code: 200
start document
[HTTP] GET...
[HTTP] GET... code: 200
start document
0: Sunday
1: Sunday Night
2: Monday
3: Monday Night
4: Tuesday
5: Tuesday Night
6: Wednesday
7: Wednesday Night
8: Thursday
9: Thursday Night
10: Friday
11: Friday Night
[HTTP] GET...
[HTTP] GET... code: 200
start document

Also whenever I touch the screen, the blue led flashes on the Wemos board.

Thanks,
David Johnson

2 Answers

0 votes
answered by (320 points)
Mine worked intermittently. Most of the time it does doing exactly the same thing you have described. My screen flickers when it starts up, and stays white from then on.
0 votes
answered by (300 points)
My color kit showed the same behaviour, until I plugged in a different Wemos. I can still use the original one, but then I need to power the display from an external 3.3V source.

Welcome to ThingPulse Q&A, where you can ask questions and receive answers from other members of the community.

https://thingpulse.com

...