0 votes
asked in ESP8266 WiFi Color Kit by (120 points)

Hi,

I recenty got my wifi color kit. Thanks for the great kit!

I assembled the header in the "large plugable" version. An image: https://postimg.org/image/6vhe83dvu3/

I got the source from github: https://github.com/squix78/esp8266-weather-station-color/commit/0cd773058c54578bb54247f07beb7a998df2b74f

The display starts to shine after the program startup but shows no contents. If I change the line 

digitalWrite(TFT_LED, HIGH);

to `LOW` the display remains dark after reprogramming.

The only changes I made are in `settings.h`. But even the original program brings nothing into the display.

With the vanilla programm the serial console only outputs dots. The output from my modifed programm: https://gist.github.com/aAXEe/bea15f0d5527df38cbfe186095b03560

Some oberservations:

If I press the screen the blue LED on the WeMos bords shines during the press.

If I shake the display lightly the background light gets darker and sometimes has some flickers.

Can somebody help me?

1 Answer

0 votes
answered by (300 points)
edited by

I have exactly the same problem in about 90% of the time when I power the kit. To isolate the problem, I used a breadboard instead of the pcb, used a different Wemos and tried some other sketches.

In my case, it's definitely the display. It's extremely sensitive in respect to (not soldered) wiring and small vibrations.

Correction: got me a new Wemos Mini Pro and now the kit works flawlessly.

Welcome to ThingPulse Q&A, where you can ask questions and receive answers from other members of the community.

https://thingpulse.com

...