0 votes
in ESPaper by (190 points)

I have a new PC and installed latest Arduino IDE 1.8.19. I wanted to make some changes to the Weather Station example for your 2.9” ESPaper kit, but I keep getting the following error when compiling the script. Can you kindly help

 In file included from Z:\Documents\Arduino\espaper-weatherstation-master_TEST\espaper-weatherstation\settings.h:11,

                  from Z:\Documents\Arduino\espaper-weatherstation-master_TEST\espaper-weatherstation\espaper-weatherstation.ino:31:

 Z:\Documents\Arduino\libraries\Mini_Grafx\src/EPD_WaveShare_29.h:62:21: error: redefinition of 'const unsigned char lut_full_update []'

    62 | const unsigned char lut_full_update[] =

       |                     ^~~~~~~~~~~~~~~

 In file included from Z:\Documents\Arduino\espaper-weatherstation-master_TEST\espaper-weatherstation\settings.h:9,

                  from Z:\Documents\Arduino\espaper-weatherstation-master_TEST\espaper-weatherstation\espaper-weatherstation.ino:31:

 Z:\Documents\Arduino\libraries\Mini_Grafx\src/EPD_WaveShare_154.h:62:21: note: 'const unsigned char lut_full_update [31]' previously defined here

    62 | const unsigned char lut_full_update[] =

       |                     ^~~~~~~~~~~~~~~

 In file included from Z:\Documents\Arduino\espaper-weatherstation-master_TEST\espaper-weatherstation\settings.h:11,

                  from Z:\Documents\Arduino\espaper-weatherstation-master_TEST\espaper-weatherstation\espaper-weatherstation.ino:31:

 Z:\Documents\Arduino\libraries\Mini_Grafx\src/EPD_WaveShare_29.h:69:21: error: redefinition of 'const unsigned char lut_partial_update []'

    69 | const unsigned char lut_partial_update[] =

       |                     ^~~~~~~~~~~~~~~~~~

 In file included from Z:\Documents\Arduino\espaper-weatherstation-master_TEST\espaper-weatherstation\settings.h:9,

                  from Z:\Documents\Arduino\espaper-weatherstation-master_TEST\espaper-weatherstation\espaper-weatherstation.ino:31:

 Z:\Documents\Arduino\libraries\Mini_Grafx\src/EPD_WaveShare_154.h:69:21: note: 'const unsigned char lut_partial_update [31]' previously defined here

    69 | const unsigned char lut_partial_update[] =

       |                     ^~~~~~~~~~~~~~~~~~

 Multiple libraries were found for "WiFiClient.h"

 Used: C:\Users\Gordon\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\3.0.2\libraries\ESP8266WiFi

 Not used: C:\Program Files (x86)\Arduino\libraries\WiFi

 Using library simpleDSTadjust at version 1.2.0 in folder: Z:\Documents\Arduino\libraries\simpleDSTadjust

 Using library Json_Streaming_Parser at version 1.0.5 in folder: Z:\Documents\Arduino\libraries\Json_Streaming_Parser

 Using library Mini_Grafx at version 1.2.6 in folder: Z:\Documents\Arduino\libraries\Mini_Grafx

 Using library SPI at version 1.0 in folder: C:\Users\Gordon\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\3.0.2\libraries\SPI

 Using library ESP8266_Weather_Station at version 2.1.0 in folder: Z:\Documents\Arduino\libraries\ESP8266_Weather_Station

 Using library ESP8266HTTPClient at version 1.2 in folder: C:\Users\Gordon\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\3.0.2\libraries\ESP8266HTTPClient

 Using library ESP8266WiFi at version 1.0 in folder: C:\Users\Gordon\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\3.0.2\libraries\ESP8266WiFi

 Using library ESP8266WebServer at version 1.0 in folder: C:\Users\Gordon\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\3.0.2\libraries\ESP8266WebServer

 exit status 1

 Error compiling for board Generic ESP8266 Module.

Kind regards,

Gordon Blair

by (18.5k points)
That's odd, I can't reproduce this and I don't see the issue. I tested with ESP8266 Arduino Core 3.0.2 (latest board manager) and the latest version of all libraries required by the the espaper-weatherstation project (Mini Grafx et al).

1 Answer

0 votes
by (190 points)
selected by
 
Best answer
Hi Marcel, thanks for looking into this. On a whim, I tried compiling with the Arduino Web Editor and it worked fine. This led me to believe that my installation of IDE and/or the code were wrong or corrupted.

I reinstalled IDE and downloaded the code to start fresh and everything is working as it should

Welcome to ThingPulse Q&A, where you can ask questions and receive answers from other members of the community.

https://thingpulse.com

...