+1 vote
in ESPaper by (170 points)

Boots, errors, blank screen, useless.

Log below, any ideas?

Boot sequence arrived in setup()
******** Client Version: "CLIENT_VERSION" ********
******** Device Type: "Espaper42Bw" ********
******** Screen Type: "" ********
Display Settings. CS: 15, RST: 2, DC: 5, BUSY: 4
Current free heap: 45768
Checking FS
WIFI_SSID = [XXX]
WIFI_PASS = [XXX]
UPDATE_INTERVAL_MINS = [20]
TIMEZONE = [Europe/London GMT0BST,M3.5.0/1,M10.5.0]
NTP_SERVERS = [uk.pool.ntp.org]
DEVICE_ID = []
DEVICE_SECRET = []
Loaded config
TOTAL_DEVICE_STARTS = [29]
SUCCESSFUL_DEVICE_STARTS = [0]
LAST_NTP_SYNC_TIME = [0]
STARTS_WITHOUT_NTP_SYNC = [26]
LAST_CYCLE_DURATION = [14950]
ACTION_AFTER_REBOOT = [0]
Loaded data file
Saved values in data file.
Button state: 1


***Time before connecting to WiFi 492
Reconnecting
WiFi connect..............................10.0.1.10
NTP sync.....Re-initializing NTP
....Re-initializing NTP
....Re-initializing NTP
....Re-initializing NTP

Failed to sync time through NTP. Giving up after 5103ms.
Setting pin modes
Starting SPI transaction
Beginning SPI
Drawing /screen
File /screen not foundWaiting until idle: 
Saved values in data file.
Free mem: 42720.
Waiting until idle: 
Start millis: 0, start time: 0, current millis: 15019 -> now: 15
Going to sleep for: 45[s]
by (170 points)
Also worth noting - no internet connectivity problems. Have fully flashed (erase all) and done config via mobile/hotspot. Can ping the IP from LAN (while it's live). Never seen the screen come up to pair to ESPaper account (have other devices, which work fine - mostly).
by (480 points)
edited by
Same problem on 2.9" e-paper plus. Failure to get any response from NTP. I had updated the program in January 2020 and have been using it without problems since. Just STOPPED getting the time a couple days ago. The weather data still works GREAT.  I thought it was my WiFi problem but after reading the printout I noticed NTP problem. I have tried several other programs and NTP seems to be working correctly.
by (13.9k points)
IIRC ESP8266 Arduino Core recently introduced changes to their NTP component(s). Hence, if you use our ESPaper Client and compile it manually against a newer version this might fail. Just from my memory...haven't done any real analysis, though.

1 Answer

0 votes
by (480 points)

I only had problem with no synced time, the display and weather has worked properly for me so this may only be a partial fix forthe stated problem.

I just rebuilt the weather station based on a new version of Arduino 1.8.13 and updated all the libraries and still NO JOY. I then started looking into code and search for "// Wait max. 3 seconds to make sure the time has been sync'ed " and at the end of this function the delay(300) was present. In response to the code comment above to wait for 3 seconds I changed the delay from 300 (0.3 seconds) to 10000 (10 seconds). If 3 secs is good, 10 should be better!  The time is now WORKING after one or two tries. Can tell by "." printed after a failure, and NO "\nFailed to sync time through NTP. Giving up after %dms.\n"  printed after sync Failure. The time on the e-paper display is now correct. The weather portion has always been working properly.

Welcome to ThingPulse Q&A, where you can ask questions and receive answers from other members of the community.

https://thingpulse.com

...