0 votes
in WeatherStationClassic by (260 points)
Hello,
I discovered a compatibility issue using the latest ESP8266 API version 2.6.3.
The method OpenWeatherMapCurrent::updateCurrentById() takes more than 10 seconds to respond and the application hangs. Using the older API version 2.5.2 the function responds immediately..
Will there come an update to be able to use the lastest ESP-API?
Regards, Klaus

1 Answer

0 votes
by (12.7k points)
selected by
 
Best answer

Thanks for the heads up. We will take a look and release an update should it turn out to be an issue we can fix in our code.

Update 2020-02-13: fixed in v2, see https://twitter.com/thingpulse/status/1216644619133423616

Welcome to ThingPulse Q&A, where you can ask questions and receive answers from other members of the community.

https://thingpulse.com

...